Ports
April 20, 2014, 09:31:30 am *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: SMF - Just Installed!
 
   Home   Help Search Login Register  
Welcome to the PORTS Forum. Please post your questions, answers, and comments relating to USB and other hardware interfaces in the appropriate forums below.

IMPORTANT! This forum is is moving to JANAXELSON.COM. The new site is live now. Try it: http://janaxelson.com/forum. Please update your bookmarks and links. After June 1, 2014, this forum will be available ONLY at janaxelson.com and links to content at lvr.com will no longer work. - Jan
Pages: [1] 2
  Print  
Author Topic: USB Mass storage driver as CDROM in Windows & MAC  (Read 5031 times)
coolsunny2012
Member
***
Posts: 19


« on: December 06, 2012, 11:26:55 am »

I am in the process of enumerating a Hybrid ISO image which will show up as CDROM in Windows & MAC and encountered with the following problem.

Hybrid ISO image is created with the following options and inserted the driver as "insmod g_mass_storage.ko file=/hybrid.iso"
mkisofs -input-charset iso8859-1 -J -r -hide-rr-moved -joliet-long -o hybrid.iso TestDir/

"insmod g_mass_storage.ko file=/hybrid.iso"
With the above options:
Image Shows up as CDROM in MAC but not in Windows (It shows up as "Removable Disk" and on double click,  it prompts to format the disk even though the image works in MAC)


"insmod g_mass_storage.ko file=/hybrid.iso cdrom=1"
With CDROM=1 option, it works in Windows but on MAC, i get the pop message as "The disk you inserted was not readable by this Computer" Ignore/Eject".


I am not sure where to start with to fix this issue. Should it be fixed in the the way i create the ISO image/Mass storage driver/Windows/MAC ??



 
Logged
Jan Axelson
Administrator
Frequent Contributor
*****
Posts: 2041


WWW
« Reply #1 on: December 06, 2012, 09:36:51 pm »

Here is a discussion on the same topic (note the followups), no solution unfortunately.

http://www.spinics.net/lists/linux-usb/msg60915.html
Logged
coolsunny2012
Member
***
Posts: 19


« Reply #2 on: December 13, 2012, 01:30:44 pm »

This has conclusion and it did work for me.. http://lkml.indiana.edu/hypermail/linux/kernel/1103.1/00583.html.
Logged
Jan Axelson
Administrator
Frequent Contributor
*****
Posts: 2041


WWW
« Reply #3 on: December 13, 2012, 02:44:38 pm »

Excellent! Thanks for reporting back.
Logged
coolsunny2012
Member
***
Posts: 19


« Reply #4 on: December 28, 2012, 04:33:31 pm »

I still see the same issue with MAC ( The disk you inserted was not readable by this computer) when I pass the FAT32/HFS  partition like "modprobe g_mass_storage file = /dev/mmcblk0p5 cdrom=1".
But it works in  MAC by creating Hybrid ISO Image ("modprobe g_mass_storage file = hybrid.iso cdrom=1).

Any ideas?
Logged
usha
Member
***
Posts: 10


« Reply #5 on: January 11, 2013, 12:17:54 am »

HI.,

 Now i have a firmware for usb mass storage.I also converted removable drive into cd-drive using that code . and i have to boot from that cd-drive . In BIOS set up cd-rom is been detected But that cd_drive was not booted.i must be boot that cd_drive.SO pls give me the suggestion where the problem arise for eg:512(USB SECTOR SIZE) to 2048(CD-ROM SECTOR SIZE ) .How can i boot bunch of cd_drive?HuhHuh??

PLS REPLY ME QUICKLY..I JST WAITING FOR UR REPLY........THANKS A LOT........
Logged
coolsunny2012
Member
***
Posts: 19


« Reply #6 on: January 11, 2013, 10:32:37 am »

You can try burning the Bootable ISO image to flash drive. Before you flash the ISO image,make sure that it works with using daemon tools (virtual cd drive). And to create the Bootable ISO image there are bunch of tools like UltarISO, linux utility mkisofs etc,.
« Last Edit: January 11, 2013, 10:34:21 am by coolsunny2012 » Logged
usha
Member
***
Posts: 10


« Reply #7 on: January 28, 2013, 04:52:00 am »

hi..thank for replay ..
                i download 2T ware tools creating the cd-drive & i import the iso image also . but that virtual drive is not been detecting in BIOS set up .
Logged
usha
Member
***
Posts: 10


« Reply #8 on: February 22, 2013, 12:49:38 am »

hi.,
      I m back with another query . I am doing mass storage project in that i appear as cd-rom & that must be booted i did that too by transfering (2048 bytes) & i did in single LUN,. But i want to enable TWO LUN one is cd-rom(2048) & another is removable (512 bytes) . plz send steps for enable 2 LUN.Thanks in advance .
Logged
Jan Axelson
Administrator
Frequent Contributor
*****
Posts: 2041


WWW
« Reply #9 on: February 23, 2013, 02:46:37 pm »

Exactly how to create multiple LUNs will vary with your device hardware and programming platform.

Be sure it has a serial number:

http://www.microchip.com/forums/m512215-p2.aspx

Also see:

http://lvr.com/mass_storage.htm
Logged
usha
Member
***
Posts: 10


« Reply #10 on: February 25, 2013, 07:43:44 am »

hi jan thank for reply.
                            i refer link which u send. In that dey said how to enable multiple LUN only.but i made that changes already (INQUIRY, READ CAPACITY & Enable TWO LUN .) And i  have  enable 2LUN & i made it open successfully but both are read as 0 bytes .In my case 1LUN(CD-ROM) must be read as 2048 bytes & another  LUN (REMOVABLE) it must be read in 512 bytes . so pls suggest me were i have to change to get both LUN read including SCSI Command.
  thank in advance.
   usha
Logged
Jan Axelson
Administrator
Frequent Contributor
*****
Posts: 2041


WWW
« Reply #11 on: February 25, 2013, 10:50:16 am »

A protocol analyzer will show what is happening on the bus and may help to isolate the problem. If you don't have a protocol analyzer, use whatever debugging tools you have to monitor the SCSI commands and responses.
Logged
usha
Member
***
Posts: 10


« Reply #12 on: February 25, 2013, 10:51:46 pm »

thank yar . i ll chech out & info you. Smiley
Logged
usha
Member
***
Posts: 10


« Reply #13 on: March 07, 2013, 12:22:05 am »

hi., i checked out. i have to appear TWO cd-rom DRIVE   & in that ONE  must be booted CD-DRIVE i did that too by transfering (2048 bytes)  & other must be  NORMAL CD-DRIVE i did too by changing code  . But i got o/p as  "FIRST  lun is ENABLE and been BOOTED successfully & another LUN  is appear as cd-rom but it file system is RAW &  show 0 BYTES it can't be open it shown ERROR(" IT CANNOT BE FORMATED "). Cry so plz suggest wht prob it ll reason for dis???.

 

thank for help... Smiley



regards,

usha.
Logged
Jan Axelson
Administrator
Frequent Contributor
*****
Posts: 2041


WWW
« Reply #14 on: March 07, 2013, 10:07:10 am »

It sounds like you've made some good progress. The error message is telling you there is a problem with the file system on the second LUN.
Logged
Pages: [1] 2
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!